Usando as funções de contagem

Leia também...

Comentários Discretos

Comentários Discretos Os comentários em células do Excel não são muito atraentes, e nem sempre queremos que sejam exibidos quando passamos o mouse por cima

Ler »

Comparativo Pokémon

Comparativo Pokémon Assim como prometido no lançamento de Pokédexcel Go o qual você pode conferir clicando aqui. Lhes apresento a planilha de comparativo pokémon. Nesta

Ler »

Remover acentos

Remover acentos Este é um problema que eu, sinceramente, nunca tive mas recentemente um dos leitores do Função Excel me passou um arquivo em que

Ler »

Usando as funções de contagem

É comum que as vezes tenhamos que contar alguma coisa em nossas planilhas, mas que nem sempre é uma tarefa simples. As vezes queremos contar quantas vezes algo se repete em uma base, mas ela é tão grande que ma tarefa fácil, se torna muito difícil e demorada.

Ou as vezes precisamos contar quantas vezes alguma coisa e outra aconteceram juntas. Por exemplo, quantas vezes o produto X foi vendido pelo vendedor Y. Ou quantas vezes o clientes Z comprou dentro de um mesmo mês.

Para esses e outros problemas que envolvem a simples arte de contar, existem algumas funções que fazem todo o trabalho por nós.

Neste artigo você irá conhecer:

CONT.NÚM = Para contar as células de um intervalo que contenham números.

CONT.VALORES = Para contar as células de um intervalo que não estão vazias.

CONTAR.VAZIO = Para contar as células de um intervalo que estão vazias.

CONT.SE = Para contar as células de um intervalo com base em um critério.

CONT.SES = Para contar as células de um intervalo com base em um ou mais critérios.

Iremos começar pelas mais simples até as mais complexas, passo-a-passo e com a ajuda de alguns exemplos.


Contando células com números usando CONT.NÚM

=CONT.NÚM(valor1; [valor2]; …)

função CONT.NÚM é uma das mais simples dessa lista. Possui apenas um argumento, que são as células ou o intervalo de células que se deseja analisar.

Assim, se quisermos contar quantas células contém números entre as células B1 e B5 temos duas  possibilidades.

  1. Informar à função célula a célula.
  2. Informar o intervalo inteiro à função.

No primeiro caso ficaria assim:

=CONT.NÚM(B1; B2; B3; B4; B5)

E no segundo caso, assim:

=CONT.NÚM(B1:B5)

Os dois tem o mesmo efeito, mas temos que concordar que é muito mais fácil utilizar o segundo método. Imagine se o intervalo de análise fosse da célula A1 até a A1000, não seria viável digitar uma a uma (A1; A2; A3 … A1000) é muito mais fácil informar o intervalo (A1:A1000).

Veja abaixo um exemplo desta função no Excel.

Usando as funções de contagem-1

Na imagem temos uma tabela que vai da célula B6 a B19 e queríamos contar quantas destas células continham números. Para isso na célula B3 inserimos a função CONT.NÚM.

Como pode ser visto na Barra de Fórmulas na parte superior da imagem o intervalo utilizado na função foi justamente aquele no qual os dados que queríamos analisar estão.

O resultado da função foi 3, como vemos na célula B3, pois em B6:B19 apenas as células B11B14B18 contêm números.


Contando células não vazias usando CONT.VALORES

=CONT.VALORES(valor1; [valor2]; …)

Olhando os argumentos da função acima você deve ter percebido que são exatamente os mesmos da função que vimos anteriormente. E realmente são e funcionam da mesma maneira.

O que significa que temos que informar somente as células ou intervalos de células que queremos analisar e o Excel automaticamente nos dirá quantas das células que indicamos contêm algum dado inserido nelas.

Usando as funções de contagem-2

Na imagem acima temos na célula B3função CONT.VALORES e nela inserimos o intervalo de análise de B6:B19.

função retorna o número 11 pois no intervalo selecionado, que contém 14 células, 3 delas estão vazias, ou seja, não contém nenhum dado e por isso não são contadas na função.


Contando células vazias usando CONTAR.VAZIO

=CONTAR.VAZIO(intervalo)

Esta função tem uma diferença em relação as outras duas anteriores, que está no seu argumento. Aqui não temos a opção de selecionar célula a célula, somente podemos selecionar um intervalo, e somente um. Enquanto que nas funções anteriores podíamos inserir vários intervalos ao mesmo tempo (Ex: A1:A10; B3:H3).

Mas isso não irá interferir nos exemplos que estamos vendo.

Então, temos que somente indicar um único intervalo de células que queremos analisar e o Excel automaticamente nos dirá quantas das células que indicamos não contêm dado inserido nelas.

Usando as funções de contagem-3

Na célula B3 está a função CONTAR.VAZIO com o intervalo B6:B19 informado.

Ao contrário da função anterior, esta nos retorna o número 3, pois no intervalo B6:B19 existem somente 3 células sem nenhum dado inserido, B11B14B18.


Contando com base em um critério usando CONT.SE

Chegamos nas funções de contagem mais relevantes e importantes.

função CONT.SE sozinha conseguiria substituir completamente as duas funções anteriores (CONTAR.VAZIO e CONT.VALORES) pois como vimos no início do artigo está é uma função que leva em consideração algum critério para fazer a contagem das células. Porém se formos parar para pensar, as duas funções que vimos anteriormente também usam um critério para contar. A CONT.VALORES usar o critério da célula conter algum dado, e a CONTAR.VAZIO usa o critério da célula não conter dados.

CONT.SE também consegue substituir a função CONT.NÚM, mas não completamente, somente se o usuário quiser contar células que tenham números maiores, menores ou iguais a alguma numero qualquer.

Vamos entender melhor esta função.

=CONT.SE(intervalo; critérios)

Onde:

intervalo → É o intervalo de células que queremos analisar. Assim como na função vista anteriormente.

critérios → Aqui o termo deveria estar no singular pois na verdade podemos inserir apenas um critério. É o que será levao em consideração para a função contar ou não a célula.

Tipos de Critérios

O critério que determinará o que queremos contar pode ser tanto algo em texto como algo em número. Vamos dizer que o nosso critério é o número 50, e queremos analisar o intervalo A1:A20. Neste caso as possibilidades que temos de montar a função são:

=CONT.SE(A1:A20;50) → Contar, no intervalo de A1:A20, quantas as células iguais a 50.

=CONT.SE(A1:A20;”<>50″) Contar, no intervalo de A1:A20, quantas as células diferentes de 50.

=CONT.SE(A1:A20;”>50″) → Contar, no intervalo de A1:A20, quantas as células maiores que 50.

=CONT.SE(A1:A20;”<50″) → Contar, no intervalo de A1:A20,  quantas as células menores que 50.

=CONT.SE(A1:A20;”>=50″) → Contar, no intervalo de A1:A20, quantas as células maiores ou iguais a 50.

=CONT.SE(A1:A20;”<=50″) → Contar, no intervalo de A1:A20, quantas as células menores ou iguais a 50.

Quando o critério é um texto (não um número) as possibilidades que temos são apenas duas.

Digamos agora que nosso critério sejam as palavras Função Excel, as possibilidades que temos são:

=CONT.SE(A1:A20;”Função Excel”) → Contar, no intervalo A1:A20, quantas células são iguais a Função Excel.

=CONT.SE(A1:A20;”<>”&”Função Excel”) → Contar, no intervalo A1:A20, quantas células são diferentes de Função Excel.

Note que quando usando um número sem nenhum caractere especial não devemos colocá-lo entre aspas, isso faria o Excel interpretá-lo como sendo um texto e não um número.

Já no caso de usarmos texto, sempre temos de colocar as aspas, caso contrário o Excel tentará identificá-lo como sendo um número.

Eu havia dito que a função CONT.SE consegue substituir as anteriores e parcialmente a CONT.NÚM. Veja como:

CONT.VALORES = CONT.SE(A1:A20;”<>”&””) → Como o CONT.VALORES conta as células que são diferentes de células vazias, seria o mesmo que usar o CONT.SE informando que o critério é ser diferente de vazio, por isso inserimos os termos <> que indicam ‘diferente de’ e as aspas sem nada dentro “” que indicam ‘vazio’.

CONTAR.VAZIO = CONT.SE(A1:A20;””) → Como o CONTAR.VAZIO conta as células que não contém dados ou vazias, seria o mesmo que usar o CONT.SE informando que o critério é ser igual a vazio, por isso inserimos somente as aspas sem nada dentro “” que indicam ‘vazio’.

CONT.NÚM = CONT.SE(A1:A20;”>=0″) → Como disse anteriormente, o CONT.SE não consegue substituir completamente o CONT.NÚM, mas caso o usuário saiba que no intervalo, caso existam número, serão sempre maiores ou iguais a 0 (zero) (por exemplo) então conseguimos usar a função dessa maneira.

Veja abaixo um exemplo prático no Excel usando o CONT.SE.

Usando as funções de contagem-4

Temos nesta imagem os dados de vendas de uma empresa qualquer para alguns de seus clientes.

O que queríamos saber é quantas das compras no período tiveram um Preço Total maior ou igual a 30.000 (trinta mil).

A função ficou assim(conforme a Barra de Formulas na imagem):

=CONT.SE(G6:G19;”>=”&C2)

G6:G19 é o intervalo onde estão os dados de Preço Total que queremos contar.

C2 é onde está o nosso critério, ou seja 30.000 (trinta mil). Poderíamos neste caso ter informado o critério como “>=30000” mas como utilizamos a célula C2 para facilitar a visualização do critério tivemos de montá-la como está.


Contando com base em um ou mais critérios usando CONT.SES

Esta função é uma extensão do CONT.SE que acabamos de ver, agora ao invés de usarmos um único critério para definir a nossa conta podemos usar vários. Esta função é capaz de substituir todas as demais que vimos (parcialmente a CONT.NÚM assim como a CONT.SE faz).

=CONT.SES(intervalo_critérios1; critérios1; …)

Onde:

intervalo_critérios1 → É o 1º intervalo de células que queremos analisar.

critérios1 → É o critério referente ao intervalo_critérios1.

Conforme escrevemos a função no Excel ela nos abrirá outros argumentos, seguindo assim:
intervalo_critérios1; critérios1; intervalo_critérios2; critérios2; intervalo_critérios3; critérios3; …

Os tipos de critérios funcionam Exatamente da mesma forma que na função CONT.SE (Na verdade é assim que funciona em qualquer função Excel).Então vamos direto a um exemplo no Excel.

Usando as funções de contagem-5

Aqui utilizamos 3 critérios. Queríamos definir quantas vezes o cliente Agroplat comprou Soja antes do dia 01/09/2015.

A função foi posta na célula C5 e está escrita da seguinte maneira:

intervalo_critérios1 → É o 1º intervalo de células que queremos analisar.

critérios1 → É o critério referente ao intervalo_critérios1.

B8:B21 = Intervalo onde está o nome do cliente.

critérios1 → C2 = A célula onde está o nome do cliente. Poderíamos ter escrito “Agroplat” ao invés de ter feito referência a uma célula. O efeito é o mesmo, mas usando uma outra célula podemos rapidamente entender a função e alterar para o nome de outro cliente.

intervalo_critérios2 → C8:C21 = Intervalo onde estão as datas das compras dos clientes.

critérios2 → “<“&”C3″ = Menor que a célula onde está a data, ou seja menor que 01/09/2015 pois queremos apenas as compras que aconteceram antes desta data. Poderíamos ter utilizado também “<“&”01/09/2015” com o mesmo efeito.

intervalo_critérios3 → D8:D21 = Intervalo onde estão os nomes do produtos comprados.

critérios3 → C4 = Célula onde está o nome do produto comprado. Poderíamos ter escrito “Soja” que teríamos o mesmo efeito.

Assim, o que pedimos para esta função contar para nós foi, quantas vezes o clientes Agroplat que aparece no intervalo B8:B21 comprou o produto Soja que aparece no intervalo C8:C21 antes do dia 01/09/2015 que aparece no intervalo B8:B21.

Saiba que poderíamos ter alterado a ordem dos dados que não haveria problema algum, por exemplo ao invés de usar o nome do cliente como o primeiro intervalo e critério, poderíamos o ter usado como o último, ou segundo, não faz diferença.


Acompanhe o Função Excel
facebook-logo youtube-logo googleplus-logo twitter-logo

E aí, o que achou?

Compartilhe

Destaques da Loja

Planilha de Controle Uber, Cabify & 99 Pop

Com a Planilha de Controle Uber, Cabify & 99 Pop você terá total controle de seus ganhos e gastos como motorista, sabendo de onde vem e para onde vai seu dinheiro.
Com esta planilha você terá em detalhes todo o fluxo de dinheiro que envolve seu trabalho como motorista, e poderá controlar melhor sua renda.

Saber mais »

Doação

Quer ajudar o Função Excel a se manter no ar, ou sente que merecemos um carinho por ter te ajudado a resolver algum problema com Excel? Que tal fazer uma doação?

Para doar mais que R$5,00 altere a quantidade de “compra” para que o número seja multiplicado por R$5,00.

Saber mais »

Histórico de Cotações

Baixe cotações históricas de ações, índices, moedas, criptomoedas, commodities e fundos em mais de 50 bolsas de valores no mundo, direto no Excel. Selecione os parâmetros desejados e deixe o arquivo fazer o resto para você, de forma rápida, simples e organizada.

Saber mais »