Função Matricial

Leia também...

Função Matricial

Se você já possui alguma prática com o Excel é provável que já tenha ouvido falar em algum momento de função ou fórmula matricial (ou não). Mas você sabe o que isso significa, e como fazer uma? Neste artigo vou falar um pouco sobre isso.

As funções/fórmulas matriciais, como o nome já diz, usam matrizes para efetuar os cálculos e exibir o resultado. Talvez você se lembre de ter visto matriz nas aulas de matemática no colégio, é daquilo que estamos falando.

Nestas funções damos ao Excel alguns argumentos em forma de intervalos, o que já fazemos normalmente em funções comuns (A1:A30 por exemplo), a diferença é que neste caso o Excel fará um cálculo (matemático ou lógico) para cada uma das células deste intervalo.


Como dizer ao Excel que uma função é matricial

Quando escrevemos uma função matricial ela é em muitas vezes semelhante a uma função normal e por conta disso o Excel a calcula como tal. Por isso precisamos sempre indicar que a função escrita deve ser calculada como matriz.

Não tem segredo, escreva a função desejada e ao invés de apertar ENTER, como sempre, aperte simultaneamente CTRL + SHIFT + ENTER.

Você notará que o Excel colocará sua função entre chaves {função matricial}.

Ao escrever sua função matricial você irá notar também que não é possível copiá-la como normalmente faria, porém é possível arrastá-la.


Exemplos de função matricial

Soma das diferenças

Com os dados da imagem abaixo podemos calcular a soma da diferença entre os valores de Dados1 e Dados2 utilizando uma única função matricial, enquanto que sem as matrizes seríamos obrigados a criar uma coluna auxiliar com as diferenças de B4-C4 … B14-C14 e depois fazer a soma.

A função é:

{=SOMA(B4:B14-C4:C14)}

O Excel percorrerá cada uma das células do intervalo fazendo a subtração entre Dados1 e Dados2 e no fim fará a soma destes resultados.


Observações

Por fazerem uma série de cálculos de uma só vez as funções matriciais podem deixar seu arquivo mais pesado, caso precise utilizar muitas delas.

E uma curiosidade, algumas funções normais do Excel já são matriciais, um exemplo é a SOMASE e a SOMASES (clique aqui caso não as conheça) pois percorrem um intervalo de células fazendo um teste lógico para cada uma delas, veja abaixo um exemplo de uma função matricial que tem o mesmo comportamento que SOMASE.

Função normal:

=SOMASE(A1:A10;”C”;B1:B10)

Função matricial:

=SOMA(SE(A1:A10=”C”;B1:B10))

Estas duas funções funcionam exatamente da mesma forma, até certa versão do Excel não existia a SOMASE sendo necessário fazer a função matricial equivalente.


Acompanhe o Função Excel
facebook-logo youtube-logo googleplus-logo twitter-logo

E aí, o que achou?

Compartilhe

Destaques da Loja

Bolão da Copa do Mundo FIFA 2018

Com o Bolão da Copa do Mundo FIFA 2018 do Função Excel, você terá um planilha super confiável, segura, fácil de mexer e de visual super profissional para controlar o bolão com seus amigos, familiares e principalmente, os colegas de trabalho.

Saber mais »

Gerador de catálogos

Com o Gerador de catálogos do Função Excel você poderá criar catálogos personalizados de maneira muito fácil e rápida.

Os catálogos são gerados em formato PDF de forma automática, basta setar as configurações desejada e o arquivo fará tudo por você.

Gere seus catálogos e alavanque suas vendas.

Saber mais »

Planilha de Controle Uber, Cabify & 99 Pop

Com a Planilha de Controle Uber, Cabify & 99 Pop você terá total controle de seus ganhos e gastos como motorista, sabendo de onde vem e para onde vai seu dinheiro.
Com esta planilha você terá em detalhes todo o fluxo de dinheiro que envolve seu trabalho como motorista, e poderá controlar melhor sua renda.

Saber mais »