Erros de Fórmula

" "

Existem 5 erros de fórmulas diferentes no Excel. Cada uma com seu próprio nome e apresentação visual ao usuário. Aprenda aqui quais são eles e como corrigir.

Se preferir, assista ao vídeo abaixo, nele explico tudo no detalhe (com mais informações do que o texto). Caso queria apenas seguir a leitura, é só descer um pouco mais.


Erro ###### no Excel

Por que acontece

Este é apenas um erro visual, não influencia em nada as suas fórmulas, ou o funcionamento normal de sua planilha.

Ele acontece quando uma célula contém um número muito grande que não pode ser exibido na largura atual daquela coluna.

Como corrigir

Você pode alterar a formatação da célula para Geral o que fará com que o número seja abreviado. Ou então apenas aumentar a largura da coluna para que o número possa ser exibido por inteiro.


Erro #NOME? no Excel

Por que acontece

Este erro aparece sempre que você escreve de forma errada o nome de uma função do Excel, fazendo com que ele não identifique qual a função você deseja utilizar. Por exemplo, escrever =SOM(A1:A10) quando o correto é =SOMA(A1:A10)

" "

Como corrigir

Confira que sua função foi digitada de maneira correta, faça a correção e tudo deve funcionar normalmente.


Erro #VALOR! no Excel

Por que acontece

Acontece quando você utiliza um argumento do tipo errado em uma fórmula ou função. Ou seja, utiliza um argumento do tipo texto onde deveria ser número, e vice-versa.

Como corrigir

Você pode utilizar funções do Excel que ignorem estas entradas errôneas ou então corrigir o erro manualmente, mudando o argumento utilizado na fórmula ou função.


Erro #DIV/0! no Excel

Por que acontece

Ocorre quando você tenta dividir qualquer coisa por 0. Como não existe divisão por 0, o Excel retorna este erro.

Como corrigir

Você pode:

  1. Mudar o divisor por algo que não seja 0.
  2. Utilizar a função SE para testar se seu divisor é 0 ou não, e evitar a divisão caso ele seja igual a 0. Por exemplo: =SE(A2=0;0;A1/A2), onde a divisão de A1 por A2 só é feita caso A2 seja diferente de 0, caso contrário o resultado é 0.
  3. Utilizar a função SEERRO para proteger sua fórmula de um possível erro. Por exemplo: =SEERRO(A1/A2;0), onde caso a divisão de A1 por A2 seja uma erro, o resultado será 0, caso contrário, a divisão é feita normalmente.

Erro #REF! no Excel

Por que acontece

Este ocorre quando você deleta um linha, coluna ou célula que estava sendo utilizada na fórmula, fazendo com que a referência seja perdida.

Como corrigir

Assim que notar o erro você pode utilizar o atalho CTRL + Z para desfazer a exclusão da célula, linha ou coluna que causou o problema, e então verificar qual a célula que está sendo utilizada na fórmula e que você está pretendendo deletar. E então faça os ajustes manualmente em sua fórmula.

Outra solução possível é a utilização de referência indireta, com a função INDIRETO, assista ao vídeo acima que explico como fazer.


Acompanhe o Função Excel
facebook-logo youtube-logo googleplus-logo twitter-logo

E aí, o que achou?