Como criar um Gerador de passwords aleatórias em Excel?

Share on facebook
Share on google
Share on twitter
Share on linkedin
Share on whatsapp
Share on telegram

Leia também...

Campo Minado no Excel

Campo Minado no Excel Lembra do clássico jogo de Campo Minado do Windows? Ele já não existe mais nas novas versões do sistema operacional. Mas

Ler »

Castelo 3D

Castelo 3D Confira o vídeo deste incrível castelo 3D feito inteiramente no Excel (na capa do artigo). Este vídeo faz parte da coleção ‘Brincando no

Ler »

Como criar um Gerador de passwords aleatórias em Excel?

O Excel é um programa incrível, e hoje vamos aprender mais uma funcionalidade que pode ter: gerador de senhas. Abaixo vamos ensinar como você pode criar um gerador de passwords aleatórias, confira!

Mais abaixo deixo o arquivo Excel utilizado neste artigo, para download, mas primeiro vamos tentar montar nós mesmos, afinal é praticando que se aprende.

Vamos começar? Primeiro, a partir da célula B3 para baixo, insira os nomes das células: ‘comprimento’, ‘letras maiúsculas’, ‘letras minúsculas’, ‘algarismos’ e ‘caracteres especiais’. Tudo sem as aspas! Ignore a célula B8, insira palavra ‘Password’, ou ‘Palavra-chave’ na B10 e ‘Aperte a tecla F9 para gerar outra password’ na célula B11.

Na célula C3, insira o número 16, ou a quantidade de caracteres alfanuméricos que desejar utilizar nas suas passwords. Nas quatro células seguintes, (para baixo), insira a palavra ‘Sim’  (sem as aspas).

Nas células de D4 até D7, insira os dados correspondentes, para facilitar deixo abaixo os dados, é só copiar e colar. Você pode fazer alterações, mas o padrão seria esse aí.

D4= ABCDEFGHIJKLMNOPQRSTUVXWYZ
D5= abcdefghijklmnopqrstuvxwyz
D6= 1234567890
D7= #@$%&(){}[]*!?<>

Outra coisa que precisamos preparar são os geradores de caracteres aleatórios, no nosso exemplo vamos permitir que nosso arquivo gere passwords de até 20 caracteres.

Assim, nas células de H3 até H22 insira os números de 1 a 20 (um em cada célula), e reserve as células de I3 à I22, usaremos elas em seguida.

Funções

Para começar, vamos construir uma sintaxe que vai incluir todos os caracteres que vamos utilizar. A fórmula para fazer isso parece meio complicada, mas é só um pouco longa. Na célula B8, escreva:

=SE(C4="Sim";D4;"")&SE(C5="Sim";D5;"")&SE(C6="Sim";D6;"")&SE=(C7="Sim";D7;"")

O & serve para ligar as várias funções ‘SE’. O que esta fórmula faz é testar as quatro células para ver se está presente a palavra ‘Sim’. Se estiver, o conjunto de caracteres correspondente é utilizado. Se a célula contiver outra coisa que não ‘Sim’ (independente de a primeira letra ser maiúscula), o conjunto de caracteres não é utilizado.

Depois vamos criar as formulas que selecionam os caracteres aleatórios, essa fórmula você deve inserir na célula I3, e depois de pronta, pode copiar a fórmula e colar até a célula I22.

=SE(H3>$C$3;"";EXT.TEXTO($B$8;ALEATÓRIOENTRE(1;NÚM.CARACT($B$8));1))

Desconstruindo a fórmula, a função NÚM.CARACT devolve o valor do comprimento de qualquer valor, neste caso é o tamanho (número de caracteres) da frase que criamos anteriormente. A função ‘ALEATÓRIOENTRE’ devolve um número aleatório entre dois valores que lhe são dados. Nesse caso, é entre 1 e o valor do comprimento obtido com a função ‘NÚM.CARACT’. A função ‘EXT.TEXTO’ devolve uma parte do texto, nesse caso será apenas um dos caracteres ao acaso. E já a função SE, verifica qual a quantidade de caracteres que queremos na nossa senha, caso já tenhamos passado do número desejado, a função impede que as demais trabalhem e apenas resulta em uma célula em branco.

Ao apertar a tecla F9, o Excel refaz todos os cálculos e gera novos caracteres.

Agora que já geramos todos os caracteres do nosso password individualmente, tudo que precisamos é juntar isso numa mesma célula, então na célula D10 inserimos uma fórmula que un todas as células de I3:I22, da seguinte maneira:

=I3&I4&I5&I6&I7&I8&I9&I10&I11&I12&I13&I14&I15&I16&I17&I18&I19&I20&I21&I22

Apesar de parecer meio “cru” visualmente, o gerador de passwords está totalmente funcional. Sempre que apertar a tecla F9, será gerada uma password diferente, com o número de caracteres especificado na célula C3.

Pronto! Agora você pode usar o Excel para gerar passwords para todas as suas contas.

Download gerador de passwords em Excel


Acompanhe o Função Excel
facebook-logo youtube-logo googleplus-logo twitter-logo

E aí, o que achou?

Compartilhe

Share on facebook
Share on twitter
Share on linkedin
Share on whatsapp
Share on telegram

Planilhas prontas

Gerador de catálogos

Com o Gerador de catálogos do Função Excel você poderá criar catálogos personalizados de maneira muito fácil e rápida.

Os catálogos são gerados em formato PDF de forma automática, basta setar as configurações desejada e o arquivo fará tudo por você.

Gere seus catálogos e alavanque suas vendas.

Saber mais »

Leia também...

Planilha de Controle Uber, Cabify & 99 Pop

Com a Planilha de Controle Uber, Cabify & 99 Pop você terá total controle de seus ganhos e gastos como motorista, sabendo de onde vem e para onde vai seu dinheiro.
Com esta planilha você terá em detalhes todo o fluxo de dinheiro que envolve seu trabalho como motorista, e poderá controlar melhor sua renda.

Saber mais »
Logo - Ícone

COMPARTILHE COM O MUNDO

Gostou do artigo? Não seja egoísta, compartilhe!

Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn
Share on whatsapp
WhatsApp

VOCÊ ESTÁ POR DENTRO?

Junte-se a lista de e-mails do Função Excel

Inscreva-se agora